Importing Solidworks .sldz error

I’ve tried multiple times to import a Solidworks project using the method outlined. (zipping files and then changing the extension to .sldz). The file will upload, but then during processing I get an error.

I tried a couple different models. Both times got an error.

How can I get these uploaded?

Hi Don,

Welcome to the forums, sorry to hear your uploads aren’t working! Our team is on holidays at the moment, but we’ll be able to go through this when we get back in the coming week. In the meantime, can you upload your files in the .STEP or .OBJ format? Also, if you’re comfortable with it, you can email with a link to your files and we can see what’s happening on our end.

Let me know what you’d like to do.


Hi @Don ,
We are currently fixing an issue with .sldz files containing the hidden folder __MACOSX when the files are zipped on a Mac.

As we are working on a fix for this in the backend, you can workaround this issue by zipping your .sldprt and .sldasm files with this terminal command instead of Macs Finder:
cd /folderContainingYourFiles
zip -r . -x ".DS_Store" -x "__MACOSX"

Then upload through our dashboard.
Let us know how you go!


Thanks. I realized the files downloaded to my Mac were already in a .zip format. I changed to .sldz and it worked.

Now I’m trying to import a more complex set of solidworks with sub assemblies — multiple .SLDASM and .SLDPRT. It only used the first .SLDASM.

Any ideas how to get all of them to work?

I’m glad you got it working!

We have fixed the issue so that __MACOSX folders are ignored even if you zip on a mac.

Right now we support a single .sldasm being processed per .sldz upload, so the first .sldasm is used and the other is ignored.
Supporting multiple .sldasm as multiple assemblies in the same upload is something we have on our feature roadmap and we’ll be building that in the future.

For now, you have to upload one .sldasm and it’s .sldprts in seperate .sldz files.